华为网络设备IPv6配置介绍

本篇我们来介绍一下在华为交换机或路由器上配置IPv6网络,关于IPv6的基础介绍可以参考本站早期
发布过的一篇文章:Internet Protocol Version 6(IPv6)介绍。这里我们将主机演示一下在华为交
换机或路由器上配置IPv6地址进行通信、配置DHCPv6、通过配置OSPFv3演示IPv6路由基础、配置IPv6
over IPv4隧道以及配置IPv4 over IPv6隧道的方法。通过本篇文章,我们将掌握基本IPv6地址的配
置方法、掌握OSPFv3路由协议的配置方法、掌握DHCPv6服务器功能的配置方法以及一些常见的IPv6命
令的使用方法。 配置IPv6 1、我们以下图中的拓扑为例,R1、R2、R3通过一台交换机互联,我们需要在这三台路由器上配置IPv6
地址,然后再启用OSPFv3以及DHCPv6。
2、首先在三台服务器的环回接口上配置IPv6全球单播地址,在所有路由器的g0/0/0接口上配置链路
本地地址(Link-local)。以下命令以R1为例,以相同的方式配置R2和R3。 ipv6 int loopback 0 ipv6 enable ipv6 address 2001:1::a 64 int g0/0/0 ipv6 enable ipv6 address fe80::1 link-local 3、配置完成后,查看并确认接口地址配置正确,并且是UP状态。 display ipv6 int g0/0/0 display ipv6 int loo0
4、配置OSPFv3,在路由器上开启OSPFv3进程,并指定三台路由器的router-id。然后在接口下使能
OSPFv3进程并指定所属区域。以下命令以R1为例,以相同的方式配置R2和R3。 ospfv3 1 router-id 1.1.1.1 int g0/0/0 ospfv3 1 area 0 int loo0 ospfv3 1 area 0 5、配置完成后,在路由器上查看OSPFv3的邻居关系。可以看到OSPF邻接关系已经形成,R1为DR,R2
为BDR,R3为DROther。 display ospfv3 peer
6、使用Ping ipv6命令检测链路本地地址和Loopback0接口的全球单地址是否可达。比如在R1上执行
以下命令,如下图可以看到网络是可达的。 ping ipv6 fe80::2 -i g0/0/0 ping ipv6 2001:3::c
7、通过抓包可以看到ICMPv6类型的报文。
8、下面我们来配置DHCPv6,在R2上开启DHCPv6服务器功能,然后创建IPv6地址池并指定地址池中IPv
6地址的前缀长度,再配置IPv6地址池中不参与自动分配的IPv6地址(通常为需要保留的网关地址)以
及DNS服务器的IPv6地址。 dhcp enable dhcpv6 duid ll dhcpv6 pool pool1 address prefix 2001:face::/64 dns-server 2001:444e:5300::1 excluded-address 2001:face::1 9、在g0/0/0接口配置IPv6地址为地址池中的网关地址,并配置DHCPv6服务器功能以及指定的地址池的
名称。 int g0/0/0 ipv6 address 2001:face::1 64 dhcpv6 server pool1
10、在R1和R3上配置DHCPv6客户端功能,并在相应的接口下配置通过DHCPv6自动获取IPv6地址功能。
同时,我们再配置一台PC自动获取IPv6地址。 dhcp enable dhcpv6 duid ll int g0/0/0 ipv6 address auto dhcp 11、在R2上查看DHCPv6地址池的信息,可以看到有三个地址通过DHCPv6分配了出去。
12、在R1和R3上查看通过DHCPv6获取到的IPv6地址。
13、在PC上查看通过DHCPv6自动获取到的IPv6地址,注意自动配置的网关为R2的G0/0/0的链路本地
地址。
14、测试一下DHCPv6地址的连通性。PC ping R2, R1 ping PC,R3 ping R1。
15、在R2上查看IPv6的路由表,可以看到loopback0的地址通过OSPFv3进行路由。
配置IPv6接口
1、以下图拓扑为例,两台交换机通过LACP链路相连,同时在两台交换机配置有两个VLAN(VLAN 100
和VLAN200)并对应有各自的主机相连接,两台交换机再与R1相连用来访问外网。
2、首先在两台交换机上启用IPv6,然后创建VLAN100和VLAN200,然后配置LACP。
ipv6
vlan batch 100 200
int eth-trunk 1
 mode lacp-static
 port link-type trunk
 port trunk-allow-pass vlan 200 300
int g0/0/1
 eth-trunk 1
 priority 100
int g0/0/2
 eth-trunk 1
 priority 100 
lacp priority 100

3、上述基本配置完成以后,创建VLANIF 100和VLANIF 200,并配置IPv6地址。以SW1为例。
int vlanif 100
 ipv6 enable
 ipv6 address fc00:1::1/64
int vlanif 200
 ipv6 enable 
 ipv6 address fc00:2::1/64

4、配置连接主机的接口,以SW1为例。
int g0/0/3
 port link-type access
 port default vlan 100

5、配置连接路由器的接口,以SW1为例。
interface g0/0/5
  port link-type hybird
  port hybrid pvid vlan 100
  port hybrid untagged vlan 100
6、两台交换机配置完成以后,为4台PC配置好对应的IPv6地址。

7、配置路由器,启用IPv6并给两个接口配置好IPv6地址。
8、配置完成,在PC1上分别ping PC2和路由器的接口地址。
9、在PC3上分别ping PC4和路由器的接口地址。
配置IPv6 over IPv4
1、如下图拓扑,R2与R3属于边界路由器,需要启动IPv4/IPv6双协议栈,并配置IPv6 over IPv4隧
道。边界路由器收到从IPv6网络侧发出来的报文后,如果报文目的地地址不是自身且下一跳接口为
Tunnel接口,就把收到的IPv6报文的数据部分加上IPv4报头,封装成IPv4报文转发到对端的边界路由
器上,对端路由器执行报文解封装,去掉IPv4报头,然后将解封后的IPv6报文发送到IPv6网络中。
2、首先配置路由器使能IPv6,并配置IPv6地址。
R1:
ipv6
int g0/0/0
 ipv6 enable
 ipv6 address 2001::1/64
R2:
ipv6
int g0/0/0
 ipv6 enable
 ipv6 address 2001::2/64
int g0/0/1
 ip address 119.1.1.2 24
R3:
ipv6
int g0/0/0
 ipv6 enable
 ipv6 address 2002::3/64
int g0/0/1
 ip address 119.1.1.3 24
R4:
ipv6
int g0/0/0
 ipv6 enable
 ipv6 address 2002::4/64

3、在R2和R3上配置IPv6 over IPv4隧道。
R2:
int tunnel 0/0/1
 ipv6 enable
 ipv6 address 2020::2 /64
 tunnel-protocol ipv6-ipv4
 source 119.1.1.2
 destination 119.1.1.3

R3:
int tunnel 0/0/1
 ipv6 enable
 ipv6 address 2020::3 /64
 tunnel-protocol ipv6-ipv4
 source 119.1.1.3
 destination 119.1.1.2
4、隧道建立完成,为R1和R4上配置IPv6默认路由。
R1:
ipv6 route-static :: 0 2001::2
R4:
ipv6 route-static :: 0 2002::3

5、为R2和R3配置静态路由,下一跳需要指向隧道对端IPv6地址。
R2:
ipv6 route-static 2002:: 64 2020::3
R3:
ipv6 route-static 2001:: 64 2020::2

6、在R1上PR4的IPv6地址,可以Ping通说明IPv6 over IPv4隧道建立成功。

发表评论