华为eNSP安装指南

eNSP(Enterprise Network Simulation Platform)是一款图形化网络仿真工具平台,可以实现网络设备
的仿真模拟。是一款免费的华为网络设备的专用模拟器,由华为官方提供。主要对企业网络路由器、交换机
进行软件仿真,完美呈现真实设备实景,支持大型网络模拟,让广大用户有机会在没有真实设备的情况下能
够模拟演练,学习网络技术。eNSP可模拟华为AR路由器、x7系列交换机的大部分特性、可模拟PC终端、Hub
、云、帧中继交换机等、仿真设备配置功能,快速学习华为命令行、可模拟大规模设备组网、可通过真实网
卡实现与真实网络设备的对接、模拟接口抓包,直观展示协议交互过程、支持单机版本和多机版本,支撑组
网培训场景。华为完全免费对外开放eNSP,直接下载安装即可使用,无需申请license。

下载eNSP
1、登录华为官网,在首页顶部点击“解决方案&服务”--“培训与认证”。

2、滚动到工具专区,点击“eNSP”进入下载页面。

3、进入到下载页面后,选择最新的版本进行下载,当前最新版本为“eNSP V100R003C00SPC100”。下载需要
先注册华为官网的账号。

4、如果官网上无法直接下载,这里提供了网盘下载连接:下载连接,提取码:mb3r
注意事项
1、eNSP只支持在Windows系统上进行安装。

2、可以通过裸机进行安装也可以通过虚拟机安装。

3、主机需要开启硬件虚拟化支持,例如Intel VT。

4、安装eNSP前,需要先在系统中安装好WinPcap,Wireshark,VirtualBox这三款软件,eNSP的正常使用
依赖于这三款软件。

5、注意VirtualBox请安装5.0版本,目前不支持最新的6.0版本。

6、安装VirtualBox时,请务必不要安装在带中文的路径下,否则可能导致仿真设备无法启动。

7、更多注意事项可以参考官方手册。
安装eNSP
1、这里我们采用VMware虚拟机的形式安装eNSP。首先在ESXi中安装一个Win10虚拟机。

2、虚拟机配置了2 vCPU、8GB RAM、100G HDD、1个网卡。

3、在Win10虚拟机中下载并安装WinPcap,Wireshark,VirtualBox。

4、将下载的eNSP安装程序解压,双击执行“eNSP_Setup”安装程序。

5、安装过程很简单,都选择默认选项直接下一步即可。

6、如果安装程序检测缺少相关程序,或者版本不对,安装将终止。安装正确的依赖软件后再重新安装
eNSP即可。
7、安装完成后,启动eNSP,如果启动后无任何报错,说明安装成功完成了。
验证eNSP
1、点击左上角的图标新建拓扑
2、选择左侧的设备,托放到右侧的空白处,这里我们选择添加一台S5700和两台S3700交换机,以及4台PC。
设备拖放成完后,点击左侧的闪电图标,选择连线类型,这里我们选择“Copper”对设备进行连线。

3、拓扑搭建完成如下图,两台S3700各连接两台PC,并与S5700建立eth-trunk,PC1与PC3将配置在VLAN10
中,PC2与PC4将配置在VLAN20中。我们将使用这个拓扑验证trunk和VLAN配置。
4、首先启动交换机SW1,右键“启动”,然后双击交换机进入控制台。

5、进入系统视图模式,修改交换机名称为“SW1”。
system-view
sysname SW1
6、创建Eth-Trunk接口并加入成员接口。
[SW1] interface eth-trunk 1
[SW1-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/2
[SW1-Eth-Trunk1] port link-type trunk
[SW1-Eth-Trunk1] port trunk allow-pass vlan 10 20
[SW1-Eth-Trunk1] quit

7、创建VLAN10和VLAN20并分别加入接口。
[SW1] vlan batch 10 20
[SW1] interface Ethernet0/0/1
[SW1-Ethernet0/0/1] port link-type access
[SW1-Ethernet0/0/1] port default vlan 10
[SW1-Ethernet0/0/1] quit
[SW1] interface Ethernet0/0/2
[SW1-Ethernet0/0/2] port link-type access
[SW1-Ethernet0/0/2] port default vlan 20
[SW1-Ethernet0/0/2] quit

8、配置对应的vlanif接口的IP地址。
[SW1]interface vlanif 10
[SW1-Vlanif10]ip address 192.168.10.2 24
[SW1-Vlanif10]quit
[SW1]interface vlanif 20
[SW1-Vlanif20]ip address 192.168.20.2 24
[SW1-Vlanif20]quit

9、配置完成后,dis current-configuration查看配置。
10、以相同的方式配置SW2,vlanif 使用如下IP地址。
VLAN 10:192.168.10.3 24
VLAN 20: 192.168.20.3 24

11、配置Core Switch,创建两个eth-trunk,分别连接SW1和SW2

12、创建VLAN 10 20,同样为其创建vlanif,使用如下IP地址。
VLAN 10:192.168.10.1 24
VLAN 20: 192.168.20.1 24
13、配置完成后,配置如下图
验证拓扑
1、为4台PC配置IP地址,IP地址分配如下:
PC1: 192.168.10.11 255.255.255.0 192.168.10.1
PC2: 192.168.20.11 255.255.255.0 192.168.20.1
PC3: 192.168.10.12 255.255.255.0 192.168.10.1
PC4: 192.168.20.12 255.255.255.0 192.168.20.1
2、验证相同VLAN间通信,PC1 ping PC3
3、验证不同VLAN间通信,PC1 ping PC4
4、通过以上配置,我们实现了通过三层交换机(Core)交换二层交换机(SW1,SW2)不同VLAN的数据,实
现了不同VLAN之间的通信。同时也验证了eNSP工作正常。最后,还需要配置存盘,避免交换机重启后导致配
置丢失。
5、保存实验拓扑环境,以后可以随时调用。
导入img文件
1、通过前面的所有操作,已经验证了eNSP的安装和使用均正常。eNSP中包含了一些常用的交换机类型,可
以直接使用,另外有一些比较大的设备img文件需要导入才可以使用,我们在下载eNSP时,同时下载了一些
img文件的压缩包,将这些压缩包解压缩。分别解压zip文件生成CE.img、NE40E.img、NE5000E.img、 NE
9000.img和CX.img 文件。

2、以启动CE12800为例, 打开eNSP客户端,在工作区添加一台NE40E设备,开启时出现导入弹
窗,添加解压生成的CE.img 包路径,导入即可。

3、img导入完成后,这台NetEngine 40E全业务路由器就可以正常使用了。其它需要导入的img以同样的方
式操作即可。

发表评论